Wednesday 1 April 2015

IPv6 Configuration (Cont.)

Configurations (Automatic IPv4-Compatible Mode)

The configurations for R1, R3, and R5 are the same as the manual IPv6 mode examples. Only the R2 and R4 configurations change. When you configure the IPv4-compatible tunnel, do not explicitly specify the tunnel destination IPv4 address. Tunnel destination is automatically calculated from the IPv6 next-hop address of the IPv6 route. In order to provide the route over such a tunnel, routing protocol with explicit neighbor address definition, such as BGP or static, is required. In this case, you need to use an IPv4 compatible IPv6 address as the BGP neighbor IPv6 address or static route next-hop address.
These examples use the serial interface on the R2 and R4 as the IPv4-compatible IPv6 address. The same serial is the tunnel source. For example, the IPv4 address 192.23.1.2 on R2 S0/0 is converted to ::192.23.1.2 in the IPv6 notation. This address is used as BGP peer IPv6 address and BGP next-hop. After all, the IPv6 BGP routes are redistributed into IPv6 RIP so that the remote ends of the network receive the information.
This tunneling technique is currently deprecated. Cisco recommends that you use the IPv6 ISATAP tunneling technique. Refer to ISATAP Tunnels for more information on this technique.
Note: There is no need to configure a tunnel destination with the automatic IPv6 mode.
R2-IPv6-IPv4 (Cisco 3640 Router)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end
R4-IPv4-IPv6 (Cisco 3640 Router)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.
The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis ofshow command output.
  • ping — Determines if a remote host is active or inactive, and the round-trip delay in communicating with the host.
  • show ipv6 route — Verifies if a route exists on the IPv6.
  • show bgp ipv6 — Verifies if BGP is running.
  • show bgp ipv6 summary — Displays summary information on the BGP running on the IPv6.
  • show ipv6 int tunnel 0 — Verifies that the tunnel is up on the IPv6, and verifies the MTU configured on the interface.

Verification Command Output for Manual IPv6 Mode

From R1, ping the IPv6 address on R5 to verify whether the tunnel transports the IPv6 through the IPv4 network.
R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms
R1-ipv6#ping 4000:1:1:1:1:1:1:1112
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms
R1-ipv6#
From R5, ping the IPv6 address on R1.
R5-ipv6#ping 2000:1:1:1:1:1:1112
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R5-ipv6#

Verification Command Output for Automatic IPv6 Mode

Ping the remote IPv6 network to verify connectivity through the tunnel.
R1-ipv6#ping 4000:1:1:1:1:1:1:1112
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112
R1-ipv6#
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds:
!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms
R5-ipv6#
If the ping fails, look at the IPv6 routing table to verify whether the route exists. Check the routing table on the other side as well. The route at the end router, such as R5 and R1, should be learned as a RIP route. This route is redistributed from BGP into RIP at R2 and R4. R2 and R4 is where the tunnel terminates and the BGP peering is configured.
R5-ipv6#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
via FE80::230:80FF:FEF3:4731, Ethernet1/2
Timers: Uptime/Expires R ::/96 [120/2]
R 2000:1:1:1:1:1:1:0/112 [120/3]
via FE80::230:80FF:FEF3:4731, Ethernet1/2
L 4000:1:1:1:1:1:1:1112/128 [0/0]
C 4000:1:1:1:1:1:1:0/112 [0/0]
via ::, Ethernet1/2 via ::, Ethernet1/2
via ::, Null0
L FE80::/10 [0/0] via ::, Null0 L FF00::/8 [0/0]
R5-ipv6#
If the remote IPv6 network is not on the end router, check the router where the tunnel terminates.
R4-ipv4-ipv6#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
via ::, Tunnel0
Timers: Uptime/Expires L ::192.34.1.4/128 [0/0] C ::/96 [0/0]
B 2000:1:1:1:1:1:1:0/112 [200/0]
via ::, Tunnel0 via ::192.23.1.2, Null
L 4000:1:1:1:1:1:1:1111/128 [0/0]
via ::, Ethernet3/0 C 4000:1:1:1:1:1:1:0/112 [0/0]
L FF00::/8 [0/0]
via ::, Ethernet3/0 L FE80::/10 [0/0] via ::, Null0 via ::, Null0
R4-ipv4-ipv6#
Because you are using IPv6 BGP to share information between the two different IPv6 networks, verify that BGP is up and running.

R4-ipv4-ipv6#show bgp ipv6
BGP table version is 3, local router ID is 192.34.1.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure Origin codes: i - IGP, e - EGP, ? - incomplete
*>i2000:1:1:1:1:1:1:0/112
Network Next Hop Metric LocPrf Weight Path ::192.23.1.2 100 0 i
R4-ipv4-ipv6#show bgp ipv6 summary
*> 4000:1:1:1:1:1:1:0/112 :: 32768 i
BGP router identifier 192.34.1.4, local AS number 100
2 network entries and 2 paths using 394 bytes of memory
BGP table version is 3, main routing table version 3
0 BGP route-map cache entries using 0 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs
0 BGP filter-list cache entries using 0 bytes of memory
::192.23.1.2 4 100 24 24 3 0 0 00:19:00 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd R4-ipv4-ipv6#
R4-ipv4-ipv6#show ipv6 int tunnel 0
Tunnel0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::C022:104
Global unicast address(es):
Joined group address(es):
::192.34.1.4, subnet is ::/96 FF02::1 FF02::2
ICMP error messages limited to one every 100 milliseconds
FF02::9 FF02::1:FF22:104 MTU is 1480 bytes
ND reachable time is 30000 milliseconds
ICMP redirects are enabled ND DAD is not supported
R4-ipv4-ipv6#
Hosts use stateless autoconfig for addresses.

No comments:

Post a Comment